What’s Vulnerable › Vulnerabilities
CVE-2024-3045: PDF Invoices & Packing Slips for WooCommerce <= 3.8.0 - Unauthenticated Stored Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-02 · updated 2026-06-17
- Weakness: CWE-79
Description
The PDF Invoices & Packing Slips for WooCommerce plugin for WordPress is vulnerable to Stored Cross-Site Scripting via several parameters in versions up to, and including, 3.8.0 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- wpovernight PDF Invoices & Packing Slips for WooCommerce: before 3.8.1 — fixed in 3.8.1
How to fix
Upgrade to a fixed version: wpovernight PDF Invoices & Packing Slips for WooCommerce 3.8.1. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/woocommerce-pdf-invoices-packing-slips/trunk/ubl/Transformers/AddressTransformer.php#L16
- https://plugins.trac.wordpress.org/changeset/3076105/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/2d0e5d24-5d65-4ed5-8086-347969cbd3ec?source=cve
- https://plugins.trac.wordpress.org/browser/woocommerce-pdf-invoices-packing-slips/trunk/ubl/Transformers/AddressTransformer.php#L16
- https://plugins.trac.wordpress.org/changeset/3076105/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/2d0e5d24-5d65-4ed5-8086-347969cbd3ec?source=cve
Get alerted when CVE-2024-3045 or the next vulnerability affects your stack