What’s Vulnerable › Vulnerabilities
CVE-2024-30510: WordPress Salon booking system plugin <= 9.5 - Arbitrary File Upload vulnerability
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-29 · updated 2026-06-17
- Weakness: CWE-434
Description
Unrestricted Upload of File with Dangerous Type vulnerability in Salon Booking System Salon booking system.This issue affects Salon booking system: from n/a through 9.5.
Affected products
- Salon booking system: before 9.5.1 — fixed in 9.5.1
How to fix
Upgrade to a fixed version: Salon booking system 9.5.1. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/salon-booking-system/wordpress-salon-booking-system-plugin-9-5-arbitrary-file-upload-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/salon-booking-system/wordpress-salon-booking-system-plugin-9-5-arbitrary-file-upload-vulnerability?_s_id=cve
Get alerted when CVE-2024-30510 or the next vulnerability affects your stack