What’s Vulnerable › Vulnerabilities
CVE-2024-30512: WordPress weForms plugin <= 1.6.20 - Broken Access Control vulnerability
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-09 · updated 2026-06-17
- Weakness: CWE-862
Description
Missing Authorization vulnerability in weForms.This issue affects weForms: from n/a through 1.6.20.
Affected products
- boldgrid weForms – Easy Drag & Drop Contact Form Builder For WordPress: before 1.6.21 — fixed in 1.6.21
How to fix
Upgrade to a fixed version: boldgrid weForms – Easy Drag & Drop Contact Form Builder For WordPress 1.6.21. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/weforms/wordpress-weforms-plugin-1-6-20-broken-access-control-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/weforms/wordpress-weforms-plugin-1-6-20-broken-access-control-vulnerability?_s_id=cve
Get alerted when CVE-2024-30512 or the next vulnerability affects your stack