What’s Vulnerable › Vulnerabilities
CVE-2024-3053: Forminator – Contact Form, Payment Form & Custom Form Builder <= 1.29.2 - Authenticated (Contributor+) Stored Cross-Site Scripting via forminator_form Shortcode
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-09 · updated 2026-06-17
- Weakness: CWE-79
Description
The Forminator – Contact Form, Payment Form & Custom Form Builder plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘id’ forminator_form shortcode attribute in versions up to, and including, 1.29.2 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level permissions and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- WPMU DEV Forminator: before 1.29.3 — fixed in 1.29.3
How to fix
Upgrade to a fixed version: WPMU DEV Forminator 1.29.3. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3066927/forminator
- https://www.wordfence.com/threat-intel/vulnerabilities/id/19439622-6396-4f10-ab71-aa243b6812fa?source=cve
- https://plugins.trac.wordpress.org/changeset/3066927/forminator
- https://www.wordfence.com/threat-intel/vulnerabilities/id/19439622-6396-4f10-ab71-aa243b6812fa?source=cve
Get alerted when CVE-2024-3053 or the next vulnerability affects your stack