What’s Vulnerable › Vulnerabilities
CVE-2024-30542: WordPress WholesaleX plugin <= 1.3.2 - Unauthenticated Privilege Escalation vulnerability
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-17 · updated 2026-06-17
- Weakness: CWE-269
Description
Improper Privilege Management vulnerability in Wholesale WholesaleX allows Privilege Escalation.This issue affects WholesaleX: from n/a through 1.3.2.
Affected products
- Wholesale Team WholesaleX: before 1.3.3 — fixed in 1.3.3
How to fix
Upgrade to a fixed version: Wholesale Team WholesaleX 1.3.3. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/wholesalex/wordpress-wholesalex-plugin-1-3-2-unauthenticated-privilege-escalation-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/wholesalex/wordpress-wholesalex-plugin-1-3-2-unauthenticated-privilege-escalation-vulnerability?_s_id=cve
Get alerted when CVE-2024-30542 or the next vulnerability affects your stack