What’s Vulnerable › Vulnerabilities
CVE-2024-3063: WPB Elementor Addons <= 1.0.9 - Authenticated (Contributor+) Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-30 · updated 2026-06-17
- Weakness: CWE-79
Description
The WPB Elementor Addons plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the output of 'tags' added to widgets in all versions up to, and including, 1.0.9 due to insufficient input sanitization and output escaping on user supplied tag attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- wpbean WPB Addons for Elementor – News Ticker, Timeline, Team & More Widgets: before 1.2 — fixed in 1.2
How to fix
Upgrade to a fixed version: wpbean WPB Addons for Elementor – News Ticker, Timeline, Team & More Widgets 1.2. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3088737%40wpb-elementor-addons&new=3088737%40wpb-elementor-addons&sfp_email=&sfph_mail=#file44
- https://www.wordfence.com/threat-intel/vulnerabilities/id/8a832e2b-a900-4057-96fc-1bd6899e3950?source=cve
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3088737%40wpb-elementor-addons&new=3088737%40wpb-elementor-addons&sfp_email=&sfph_mail=#file44
- https://www.wordfence.com/threat-intel/vulnerabilities/id/8a832e2b-a900-4057-96fc-1bd6899e3950?source=cve
Get alerted when CVE-2024-3063 or the next vulnerability affects your stack