What’s Vulnerable › Vulnerabilities
CVE-2024-3068: Custom Field Suite <= 2.6.5 - Authenticated (Admin+) Stored Cross-Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-14 · updated 2026-06-17
- Weakness: CWE-79
Description
The Custom Field Suite plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'cfs[fields][*][name]' parameter in all versions up to, and including, 2.6.5 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with administrator-level access, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This only affects multi-site installations and installations where unfiltered_html has been disabled.
Affected products
- mgibbs189 Custom Field Suite: before 2.6.6 — fixed in 2.6.6
How to fix
Upgrade to a fixed version: mgibbs189 Custom Field Suite 2.6.6. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/custom-field-suite/trunk/templates/field_html.php?order=date&desc=1#L46
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&new=3080330%40custom-field-suite%2Ftrunk&old=3042177%40custom-field-suite%2Ftrunk&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/0ab546cc-b099-4d26-bf42-785952fcfd8c?source=cve
- https://plugins.trac.wordpress.org/browser/custom-field-suite/trunk/templates/field_html.php?order=date&desc=1#L46
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&new=3080330%40custom-field-suite%2Ftrunk&old=3042177%40custom-field-suite%2Ftrunk&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/0ab546cc-b099-4d26-bf42-785952fcfd8c?source=cve
Get alerted when CVE-2024-3068 or the next vulnerability affects your stack