What’s Vulnerable › Vulnerabilities
CVE-2024-3081: EasyCorp EasyAdmin Autocomplete autocomplete.js cross site scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-29 · updated 2026-06-17
- Weakness: CWE-79
Description
A vulnerability was found in EasyCorp EasyAdmin up to 4.8.9. It has been declared as problematic. Affected by this vulnerability is the function Autocomplete of the file assets/js/autocomplete.js of the component Autocomplete. The manipulation of the argument item leads to cross site scripting. The attack can be launched remotely. Upgrading to version 4.8.10 is able to address this issue. The identifier of the patch is 127436e4c3f56276d548070f99e61b7234200a11. It is recommended to upgrade the affected component. The identifier VDB-258613 was assigned to this vulnerability.
Affected products
- EasyCorp EasyAdmin: through 4.8.9
References
- https://github.com/EasyCorp/EasyAdminBundle/commit/127436e4c3f56276d548070f99e61b7234200a11
- https://github.com/EasyCorp/EasyAdminBundle/pull/5971
- https://github.com/EasyCorp/EasyAdminBundle/pull/6067
- https://github.com/EasyCorp/EasyAdminBundle/releases/tag/v4.8.10
- https://vuldb.com/?ctiid.258613
- https://vuldb.com/?id.258613
- https://github.com/EasyCorp/EasyAdminBundle/commit/127436e4c3f56276d548070f99e61b7234200a11
- https://github.com/EasyCorp/EasyAdminBundle/pull/5971
- https://github.com/EasyCorp/EasyAdminBundle/pull/6067
- https://github.com/EasyCorp/EasyAdminBundle/releases/tag/v4.8.10
- https://vuldb.com/?ctiid.258613
- https://vuldb.com/?id.258613
Get alerted when CVE-2024-3081 or the next vulnerability affects your stack