What’s Vulnerable › Vulnerabilities
CVE-2024-3098: Prompt Injection leading to Arbitrary Code Execution in run-llama/llama_index
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-10 · updated 2026-06-17
- Weakness: CWE-94
Description
A vulnerability was identified in the `exec_utils` class of the `llama_index` package, specifically within the `safe_eval` function, allowing for prompt injection leading to arbitrary code execution. This issue arises due to insufficient validation of input, which can be exploited to bypass method restrictions and execute unauthorized code. The vulnerability is a bypass of the previously addressed CVE-2023-39662, demonstrated through a proof of concept that creates a file on the system by exploiting the flaw.
Affected products
- run-llama Llama Index: before 0.10.24 — fixed in 0.10.24
How to fix
Upgrade to a fixed version: run-llama Llama Index 0.10.24. Check the vendor advisory for mitigations.
References
- https://github.com/run-llama/llama_index/commit/5fbcb5a8b9f20f81b791c7fc8849e352613ab475
- https://huntr.com/bounties/1bce0d61-ad03-4b22-bc32-8f99f92974e7
- https://github.com/run-llama/llama_index/commit/5fbcb5a8b9f20f81b791c7fc8849e352613ab475
- https://huntr.com/bounties/1bce0d61-ad03-4b22-bc32-8f99f92974e7
Get alerted when CVE-2024-3098 or the next vulnerability affects your stack