What’s Vulnerable › Vulnerabilities
CVE-2024-31047
- Severity: low (CVSS 3.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-04-08 · updated 2026-06-17
- Weakness: CWE-190
Description
An issue in Academy Software Foundation openexr v.3.2.3 and before allows a local attacker to cause a denial of service (DoS) via the convert function of exrmultipart.cpp.
Affected products
- AcademySoftwareFoundation openexr: before 3.2.4 — fixed in 3.2.4
How to fix
Upgrade to a fixed version: AcademySoftwareFoundation openexr 3.2.4. Check the vendor advisory for mitigations.
References
- https://github.com/AcademySoftwareFoundation/openexr/issues/1680
- https://github.com/AcademySoftwareFoundation/openexr/issues/1680
Get alerted when CVE-2024-31047 or the next vulnerability affects your stack