What’s Vulnerable › Vulnerabilities
CVE-2024-3111: H5P < 1.15.8 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-06-27 · updated 2026-06-17
- Weakness: CWE-79
Description
The Interactive Content WordPress plugin before 1.15.8 does not validate uploads which could allow a Contributors and above to update malicious SVG files, leading to Stored Cross-Site Scripting issues
Affected products
- H5P: before 1.15.8 — fixed in 1.15.8
How to fix
Upgrade to a fixed version: H5P 1.15.8. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/7c39f3b5-d407-4eb0-aa34-b498fe196c55/
- https://wpscan.com/vulnerability/7c39f3b5-d407-4eb0-aa34-b498fe196c55/
Get alerted when CVE-2024-3111 or the next vulnerability affects your stack