What’s Vulnerable › Vulnerabilities
CVE-2024-31142: x86: Incorrect logic for BTC/SRSO mitigations
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 17.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-16 · updated 2026-06-17
- Weakness: CWE-693
Description
Because of a logical error in XSA-407 (Branch Type Confusion), the mitigation is not applied properly when it is intended to be used. XSA-434 (Speculative Return Stack Overflow) uses the same infrastructure, so is equally impacted. For more details, see: https://xenbits.xen.org/xsa/advisory-407.html https://xenbits.xen.org/xsa/advisory-434.html
Affected products
- Fedoraproject Fedora: 38, 40
- xen: before 4.15.6; from 4.16.0 before 4.16.6; from 4.17.0 before 4.17.4; from 4.18.0 before 4.18.2 — fixed in 4.15.6, 4.16.6, 4.17.4, 4.18.2
How to fix
Upgrade to a fixed version: xen 4.15.6, 4.16.6, 4.17.4, 4.18.2. Check the vendor advisory for mitigations.
References
- https://xenbits.xenproject.org/xsa/advisory-455.html
- http://xenbits.xen.org/xsa/advisory-455.html
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/D5OK6MH75S7YWD34EWW7QIZTS627RIE3/
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/RYAZ7P6YFJ2E3FHKAGIKHWS46KYMMTZH/
- https://xenbits.xenproject.org/xsa/advisory-455.html
Get alerted when CVE-2024-31142 or the next vulnerability affects your stack