What’s Vulnerable › Vulnerabilities
CVE-2024-3120: Stack-Buffer Overflow in 'Content-Length' and 'Warning' Header Processing in sngrep
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-10 · updated 2026-06-17
- Weakness: CWE-120
Description
A stack-buffer overflow vulnerability exists in all versions of sngrep since v1.4.1. The flaw is due to inadequate bounds checking when copying 'Content-Length' and 'Warning' headers into fixed-size buffers in the sip_validate_packet and sip_parse_extra_headers functions within src/sip.c. This vulnerability allows remote attackers to execute arbitrary code or cause a denial of service (DoS) via crafted SIP messages.
Affected products
- irontec sngrep: from 1.4.1 before 1.8.1 — fixed in 1.8.1
How to fix
Upgrade to a fixed version: irontec sngrep 1.8.1. Check the vendor advisory for mitigations.
References
- https://github.com/irontec/sngrep/pull/480/commits/f229a5d31b0be6a6cc3ab4cd9bfa4a1b5c5714c6
- https://github.com/irontec/sngrep/releases/tag/v1.8.1
- https://pentraze.com/vulnerability-reports/
- https://github.com/irontec/sngrep/pull/480/commits/f229a5d31b0be6a6cc3ab4cd9bfa4a1b5c5714c6
- https://github.com/irontec/sngrep/releases/tag/v1.8.1
- https://pentraze.com/vulnerability-reports/
Get alerted when CVE-2024-3120 or the next vulnerability affects your stack