What’s Vulnerable › Vulnerabilities
CVE-2024-31217: @strapi/plugin-upload has a Denial-of-Service via Improper Exception Handling
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-06-12 · updated 2026-06-17
- Weakness: CWE-248
Description
Strapi is an open-source content management system. Prior to version 4.22.0, a denial-of-service vulnerability is present in the media upload process causing the server to crash without restarting, affecting either development and production environments. Usually, errors in the application cause it to log the error and keep it running for other clients. This behavior, in contrast, stops the server execution, making it unavailable for any clients until it's manually restarted. Any user with access to the file upload functionality is able to exploit this vulnerability, affecting applications running in both development mode and production mode as well. Users should upgrade @strapi/plugin-upload to version 4.22.0 to receive a patch.
Affected products
- strapi: before 4.22.0 — fixed in 4.22.0
How to fix
Upgrade to a fixed version: strapi 4.22.0. Check the vendor advisory for mitigations.
References
- https://github.com/strapi/strapi/commit/a0da7e73e1496d835fe71a2febb14f70170135c7
- https://github.com/strapi/strapi/security/advisories/GHSA-pm9q-xj9p-96pm
- https://github.com/strapi/strapi/commit/a0da7e73e1496d835fe71a2febb14f70170135c7
- https://github.com/strapi/strapi/security/advisories/GHSA-pm9q-xj9p-96pm
Get alerted when CVE-2024-31217 or the next vulnerability affects your stack