What’s Vulnerable › Vulnerabilities
CVE-2024-31224: GPT Academic: Pickle deserializing cookies may pose RCE risk
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-08 · updated 2026-06-17
- Weakness: CWE-502
Description
GPT Academic provides interactive interfaces for large language models. A vulnerability was found in gpt_academic versions 3.64 through 3.73. The server deserializes untrustworthy data from the client, which may risk remote code execution. Any device that exposes the GPT Academic service to the Internet is vulnerable. Version 3.74 contains a patch for the issue. There are no known workarounds aside from upgrading to a patched version.
Affected products
- binary-husky/gpt_academic: from 3.64-1 before 3.74 — fixed in 3.74
How to fix
Upgrade to a fixed version: binary-husky/gpt_academic 3.74. Check the vendor advisory for mitigations.
References
- https://github.com/binary-husky/gpt_academic/commit/8af6c0cab6d96f5c4520bec85b24802e6e823f35
- https://github.com/binary-husky/gpt_academic/pull/1648
- https://github.com/binary-husky/gpt_academic/security/advisories/GHSA-jcjc-89wr-vv7g
- https://github.com/binary-husky/gpt_academic/commit/8af6c0cab6d96f5c4520bec85b24802e6e823f35
- https://github.com/binary-husky/gpt_academic/pull/1648
- https://github.com/binary-husky/gpt_academic/security/advisories/GHSA-jcjc-89wr-vv7g
Get alerted when CVE-2024-31224 or the next vulnerability affects your stack