What’s Vulnerable › Vulnerabilities
CVE-2024-31227: Denial-of-service due to malformed ACL selectors in Redis
- Severity: medium (CVSS 4.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-07 · updated 2026-06-17
- Weakness: CWE-20
Description
Redis is an open source, in-memory database that persists on disk. An authenticated with sufficient privileges may create a malformed ACL selector which, when accessed, triggers a server panic and subsequent denial of service. The problem exists in Redis 7 prior to versions 7.2.6 and 7.4.1. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Affected products
- Redis: from 7.0.0 before 7.2.6; 7.4.0 — fixed in 7.2.6
How to fix
Upgrade to a fixed version: Redis 7.2.6. Check the vendor advisory for mitigations.
References
- https://github.com/redis/redis/commit/b351d5a3210e61cc3b22ba38a723d6da8f3c298a
- https://github.com/redis/redis/security/advisories/GHSA-38p4-26x2-vqhh
Get alerted when CVE-2024-31227 or the next vulnerability affects your stack