What’s Vulnerable › Vulnerabilities
CVE-2024-31240: WordPress WP Poll Maker plugin <= 3.1 - Auth. Arbitrary File Deletion vulnerability
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-10 · updated 2026-06-17
- Weakness: CWE-22
Description
Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability in InfoTheme WP Poll Maker.This issue affects WP Poll Maker: from n/a through 3.1.
Affected products
- Poll Maker & Voting Plugin Team (InfoTheme) WP Poll Maker: before 3.4 — fixed in 3.4
How to fix
Upgrade to a fixed version: Poll Maker & Voting Plugin Team (InfoTheme) WP Poll Maker 3.4. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/epoll-wp-voting/wordpress-wp-poll-maker-plugin-3-1-subscriber-arbitrary-file-deletion-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/epoll-wp-voting/wordpress-wp-poll-maker-plugin-3-1-subscriber-arbitrary-file-deletion-vulnerability?_s_id=cve
Get alerted when CVE-2024-31240 or the next vulnerability affects your stack