What’s Vulnerable › Vulnerabilities
CVE-2024-31243: WordPress Bricksforge plugin <= 2.0.17 - Unauthenticated Arbitrary WordPress Setting Deletion vulnerability
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-09 · updated 2026-06-17
- Weakness: CWE-862
Description
Missing Authorization vulnerability in Bricksforge.This issue affects Bricksforge: from n/a through 2.0.17.
Affected products
- Bricksforge: before 2.1.1 — fixed in 2.1.1
How to fix
Upgrade to a fixed version: Bricksforge 2.1.1. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/bricksforge/wordpress-bricksforge-plugin-2-0-17-unauthenticated-arbitrary-wordpress-setting-deletion-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/bricksforge/wordpress-bricksforge-plugin-2-0-17-unauthenticated-arbitrary-wordpress-setting-deletion-vulnerability?_s_id=cve
Get alerted when CVE-2024-31243 or the next vulnerability affects your stack