What’s Vulnerable › Vulnerabilities
CVE-2024-31245: WordPress ConvertKit plugin <= 2.4.5 - Email Disclosure in Log File vulnerability
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-10 · updated 2026-08-12
- Weakness: CWE-532
Description
Insertion of Sensitive Information into Log File vulnerability in ConvertKit.This issue affects ConvertKit: from n/a through 2.4.5.
Affected products
- ConvertKit: before 2.4.6 — fixed in 2.4.6
How to fix
Upgrade to a fixed version: ConvertKit 2.4.6. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/convertkit/wordpress-convertkit-plugin-2-4-5-email-disclosure-in-log-file-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/convertkit/wordpress-convertkit-plugin-2-4-5-email-disclosure-in-log-file-vulnerability?_s_id=cve
Get alerted when CVE-2024-31245 or the next vulnerability affects your stack