What’s Vulnerable › Vulnerabilities
CVE-2024-31252: WordPress Responsive Lightbox & Gallery plugin <= 2.4.6 - Broken Access Control vulnerability
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-09 · updated 2026-06-17
- Weakness: CWE-862
Description
Missing Authorization vulnerability in dFactory Responsive Lightbox.This issue affects Responsive Lightbox: from n/a through 2.4.6.
Affected products
- dFactory Responsive Lightbox & Gallery: before 2.4.7 — fixed in 2.4.7
How to fix
Upgrade to a fixed version: dFactory Responsive Lightbox & Gallery 2.4.7. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/responsive-lightbox/wordpress-responsive-lightbox-gallery-plugin-2-4-6-broken-access-control-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/responsive-lightbox/wordpress-responsive-lightbox-gallery-plugin-2-4-6-broken-access-control-vulnerability?_s_id=cve
Get alerted when CVE-2024-31252 or the next vulnerability affects your stack