What’s Vulnerable › Vulnerabilities
CVE-2024-31253: WordPress WP OAuth Server (OAuth Authentication) plugin <= 4.3.3 - Open Redirection vulnerability
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-10 · updated 2026-06-17
- Weakness: CWE-601
Description
URL Redirection to Untrusted Site ('Open Redirect') vulnerability in WP OAuth Server OAuth Server.This issue affects OAuth Server: from n/a through 4.3.3.
Affected products
- WP OAuth Server (OAuth Authentication): before 4.4.0 — fixed in 4.4.0
How to fix
Upgrade to a fixed version: WP OAuth Server (OAuth Authentication) 4.4.0. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/oauth2-provider/wordpress-wp-oauth-server-oauth-authentication-plugin-4-3-3-open-redirection-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/oauth2-provider/wordpress-wp-oauth-server-oauth-authentication-plugin-4-3-3-open-redirection-vulnerability?_s_id=cve
Get alerted when CVE-2024-31253 or the next vulnerability affects your stack