What’s Vulnerable › Vulnerabilities
CVE-2024-31259: WordPress SearchIQ plugin <= 4.5 - Sensitive Data Exposure via Log File vulnerability
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-10 · updated 2026-06-17
- Weakness: CWE-532
Description
Insertion of Sensitive Information into Log File vulnerability in Searchiq SearchIQ.This issue affects SearchIQ: from n/a through 4.5.
Affected products
- SearchIQ: before 4.6 — fixed in 4.6
How to fix
Upgrade to a fixed version: SearchIQ 4.6. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/searchiq/wordpress-searchiq-plugin-4-5-sensitive-data-exposure-via-log-file-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/searchiq/wordpress-searchiq-plugin-4-5-sensitive-data-exposure-via-log-file-vulnerability?_s_id=cve
Get alerted when CVE-2024-31259 or the next vulnerability affects your stack