What’s Vulnerable › Vulnerabilities
CVE-2024-3126: Command Injection in parisneo/lollms-webui
- Severity: high (CVSS 8.4 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-05-16 · updated 2026-06-17
- Weakness: CWE-78
Description
A command injection vulnerability exists in the 'run_xtts_api_server' function of the parisneo/lollms-webui application, specifically within the 'lollms_xtts.py' script. The vulnerability arises due to the improper neutralization of special elements used in an OS command. The affected function utilizes 'subprocess.Popen' to execute a command constructed with a Python f-string, without adequately sanitizing the 'xtts_base_url' input. This flaw allows attackers to execute arbitrary commands remotely by manipulating the 'xtts_base_url' parameter. The vulnerability affects versions up to and including the latest version before 9.5. Successful exploitation could lead to arbitrary remote code execution (RCE) on the system where the application is deployed.
Affected products
- ParisNeo lollms-webui: before 9.5 — fixed in 9.5
How to fix
Upgrade to a fixed version: ParisNeo lollms-webui 9.5. Check the vendor advisory for mitigations.
References
- https://github.com/parisneo/lollms-webui/commit/41dbb1b3f2e78ea276e5269544e50514252c0c25
- https://huntr.com/bounties/0e2bec70-826e-4c24-8015-31921e23fd12
- https://github.com/parisneo/lollms-webui/commit/41dbb1b3f2e78ea276e5269544e50514252c0c25
- https://huntr.com/bounties/0e2bec70-826e-4c24-8015-31921e23fd12
Get alerted when CVE-2024-3126 or the next vulnerability affects your stack