What’s Vulnerable › Vulnerabilities

CVE-2024-3127: Improper Access Control in GitLab

Description

An issue has been discovered in GitLab EE affecting all versions starting from 12.5 before 17.1.6, all versions starting from 17.2 before 17.2.4, all versions starting from 17.3 before 17.3.1. Under certain conditions it may be possible to bypass the IP restriction for groups through GraphQL allowing unauthorised users to perform some actions at the group level.

Affected products

How to fix

Upgrade to a fixed version: GitLab 17.1.6, 17.2.4. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-3127 or the next vulnerability affects your stack