What’s Vulnerable › Vulnerabilities
CVE-2024-31359: WordPress Premmerce Product Filter for WooCommerce plugin <= 3.7.2 - Broken Access Control vulnerability
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-09 · updated 2026-06-17
- Weakness: CWE-862
Description
Missing Authorization vulnerability in Premmerce Premmerce Product Filter for WooCommerce premmerce-woocommerce-product-filter.This issue affects Premmerce Product Filter for WooCommerce: from n/a through <= 3.7.2.
Affected products
- Premmerce Product Filter for WooCommerce: before 3.7.3 — fixed in 3.7.3
How to fix
Upgrade to a fixed version: Premmerce Product Filter for WooCommerce 3.7.3. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/Wordpress/Plugin/premmerce-woocommerce-product-filter/vulnerability/wordpress-premmerce-product-filter-for-woocommerce-plugin-3-7-2-broken-access-control-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/premmerce-woocommerce-product-filter/wordpress-premmerce-product-filter-for-woocommerce-plugin-3-7-2-broken-access-control-vulnerability?_s_id=cve
Get alerted when CVE-2024-31359 or the next vulnerability affects your stack