What’s Vulnerable › Vulnerabilities
CVE-2024-31371: WordPress WP Event Aggregator plugin <= 1.7.6 - Cross Site Request Forgery (CSRF) vulnerability
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-12 · updated 2026-06-17
- Weakness: CWE-352
Description
Cross-Site Request Forgery (CSRF) vulnerability in Xylus Themes WP Event Aggregator.This issue affects WP Event Aggregator: from n/a through 1.7.6.
Affected products
- Xylus Themes WP Event Aggregator: before 1.7.7 — fixed in 1.7.7
How to fix
Upgrade to a fixed version: Xylus Themes WP Event Aggregator 1.7.7. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/wp-event-aggregator/wordpress-wp-event-aggregator-plugin-1-7-6-cross-site-request-forgery-csrf-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/wp-event-aggregator/wordpress-wp-event-aggregator-plugin-1-7-6-cross-site-request-forgery-csrf-vulnerability?_s_id=cve
Get alerted when CVE-2024-31371 or the next vulnerability affects your stack