What’s Vulnerable › Vulnerabilities
CVE-2024-31373: WordPress E2Pdf plugin <= 1.20.27 - Cross Site Request Forgery (CSRF) vulnerability
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-15 · updated 2026-06-17
- Weakness: CWE-352
Description
Cross-Site Request Forgery (CSRF) vulnerability in E2Pdf e2pdf e2pdf.This issue affects e2pdf: from n/a through <= 1.20.27.
Affected products
- e2pdf: before 1.23.00 — fixed in 1.23.00
How to fix
Upgrade to a fixed version: e2pdf 1.23.00. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/Wordpress/Plugin/e2pdf/vulnerability/wordpress-e2pdf-plugin-1-20-27-cross-site-request-forgery-csrf-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/e2pdf/wordpress-e2pdf-plugin-1-20-27-cross-site-request-forgery-csrf-vulnerability?_s_id=cve
Get alerted when CVE-2024-31373 or the next vulnerability affects your stack