What’s Vulnerable › Vulnerabilities
CVE-2024-31374: WordPress AppPresser plugin <= 4.3.0 - Cross Site Request Forgery (CSRF) vulnerability
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-15 · updated 2026-06-17
- Weakness: CWE-352
Description
Cross-Site Request Forgery (CSRF) vulnerability in Scott Bolinger AppPresser apppresser allows Cross Site Request Forgery.This issue affects AppPresser: from n/a through <= 4.3.0.
Affected products
- scottopolis AppPresser – Mobile App Framework: before 4.3.1 — fixed in 4.3.1
How to fix
Upgrade to a fixed version: scottopolis AppPresser – Mobile App Framework 4.3.1. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/Wordpress/Plugin/apppresser/vulnerability/wordpress-apppresser-mobile-app-framework-plugin-4-3-0-cross-site-request-forgery-csrf-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/apppresser/wordpress-apppresser-mobile-app-framework-plugin-4-3-0-cross-site-request-forgery-csrf-vulnerability?_s_id=cve
Get alerted when CVE-2024-31374 or the next vulnerability affects your stack