What’s Vulnerable › Vulnerabilities
CVE-2024-31406
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-24 · updated 2026-06-17
- Weakness: CWE-489
Description
Active debug code vulnerability exists in RoamWiFi R10 prior to 4.8.45. If this vulnerability is exploited, a network-adjacent unauthenticated attacker with access to the device may perform unauthorized operations.
Affected products
- Roamwifi R10: before 4.8.45 — fixed in 4.8.45
How to fix
Upgrade to a fixed version: Roamwifi R10 4.8.45. Check the vendor advisory for mitigations.
References
- https://jvn.jp/en/jp/JVN62737544/
- https://www.roamwifi.hk/product.jsp
- https://jvn.jp/en/jp/JVN62737544/
- https://www.roamwifi.hk/product.jsp
Get alerted when CVE-2024-31406 or the next vulnerability affects your stack