What’s Vulnerable › Vulnerabilities
CVE-2024-31411: Apache StreamPipes: Potential remote code execution (RCE) via file upload
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-17 · updated 2026-06-17
- Weakness: CWE-434
Description
Unrestricted Upload of File with dangerous type vulnerability in Apache StreamPipes. Such a dangerous type might be an executable file that may lead to a remote code execution (RCE). The unrestricted upload is only possible for authenticated and authorized users. This issue affects Apache StreamPipes: through 0.93.0. Users are recommended to upgrade to version 0.95.0, which fixes the issue.
Affected products
- Apache Software Foundation Apache StreamPipes: before 0.95.0 — fixed in 0.95.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache StreamPipes 0.95.0. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/b0657okbwzg5xxs11hphvc9qrd9s70mt
- http://www.openwall.com/lists/oss-security/2024/07/16/10
- https://lists.apache.org/thread/b0657okbwzg5xxs11hphvc9qrd9s70mt
Get alerted when CVE-2024-31411 or the next vulnerability affects your stack