What’s Vulnerable › Vulnerabilities
CVE-2024-31415
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-13 · updated 2026-06-17
- Weakness: CWE-312
Description
The Eaton Foreseer software provides the feasibility for the user to configure external servers for multiple purposes such as network management, user management, etc. The software uses encryption to store these configurations securely on the host machine. However, the keys used for this encryption were insecurely stored, which could be abused to possibly change or remove the server configuration.
Affected products
- Eaton Foreseer: before 7.8.600 — fixed in 7.8.600
How to fix
Upgrade to a fixed version: Eaton Foreseer 7.8.600. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-31415 or the next vulnerability affects your stack