What’s Vulnerable › Vulnerabilities
CVE-2024-31416
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-13 · updated 2026-06-17
- Weakness: CWE-190
Description
The Eaton Foreseer software provides multiple customizable input fields for the users to configure parameters in the tool like alarms, reports, etc. Some of these input fields were not checking the length and bounds of the entered value. The exploit of this security flaw by a bad actor may result in excessive memory consumption or integer overflow.
Affected products
- Eaton Foreseer: before 7.8.600 — fixed in 7.8.600
How to fix
Upgrade to a fixed version: Eaton Foreseer 7.8.600. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-31416 or the next vulnerability affects your stack