What’s Vulnerable › Vulnerabilities
CVE-2024-31444: Cacti XSS vulnerability in lib/html.php by reading dirty data stored in database
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 14.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-05-14 · updated 2026-06-17
- Weakness: CWE-79
Description
Cacti provides an operational monitoring and fault management framework. Prior to version 1.2.27, some of the data stored in `automation_tree_rules_form_save()` function in `automation_tree_rules.php` is not thoroughly checked and is used to concatenate the HTML statement in `form_confirm()` function from `lib/html.php` , finally resulting in cross-site scripting. Version 1.2.27 contains a patch for the issue.
Affected products
- cacti: before 1.2.27 — fixed in 1.2.27
- Fedoraproject Fedora: 39
How to fix
Upgrade to a fixed version: cacti 1.2.27. Check the vendor advisory for mitigations.
References
- https://github.com/Cacti/cacti/security/advisories/GHSA-p4ch-7hjw-6m87
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/RBEOAFKRARQHTDIYSL723XAFJ2Q6624X/
- https://github.com/Cacti/cacti/security/advisories/GHSA-p4ch-7hjw-6m87
- https://lists.debian.org/debian-lts-announce/2024/09/msg00027.html
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/RBEOAFKRARQHTDIYSL723XAFJ2Q6624X/
Get alerted when CVE-2024-31444 or the next vulnerability affects your stack