What’s Vulnerable › Vulnerabilities
CVE-2024-31448: Cross-site Scripting vulnerability in link CSV import in Combodo iTop
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-05 · updated 2026-06-17
- Weakness: CWE-79
Description
Combodo iTop is a simple, web based IT Service Management tool. By filling malicious code in a CSV content, an Cross-site Scripting (XSS) attack can be performed when importing this content. This issue has been fixed in versions 3.1.2 and 3.2.0. All users are advised to upgrade. Users unable to upgrade should validate CSV content before importing it.
Affected products
- Combodo iTop: before 3.1.2 — fixed in 3.1.2
How to fix
Upgrade to a fixed version: Combodo iTop 3.1.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-31448 or the next vulnerability affects your stack