What’s Vulnerable › Vulnerabilities
CVE-2024-31449: Lua library commands may lead to stack overflow and RCE in Redis
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-07 · updated 2026-06-17
- Weakness: CWE-20
Description
Redis is an open source, in-memory database that persists on disk. An authenticated user may use a specially crafted Lua script to trigger a stack buffer overflow in the bit library, which may potentially lead to remote code execution. The problem exists in all versions of Redis with Lua scripting. This problem has been fixed in Redis versions 6.2.16, 7.2.6, and 7.4.1. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Affected products
- Redis: from 2.8.18 before 6.2.16; from 7.2.0 before 7.2.6; 7.4.0, 7.4.0-rc1, 7.4.0-rc2 — fixed in 6.2.16, 7.2.6
How to fix
Upgrade to a fixed version: Redis 6.2.16, 7.2.6. Check the vendor advisory for mitigations.
References
- https://github.com/redis/redis/commit/1f7c148be2cbacf7d50aa461c58b871e87cc5ed9
- https://github.com/redis/redis/security/advisories/GHSA-whxg-wx83-85p5
Get alerted when CVE-2024-31449 or the next vulnerability affects your stack