What’s Vulnerable › Vulnerabilities
CVE-2024-31456: GLPI contains an authenticated SQL injection
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 59.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-07 · updated 2026-06-17
- Weakness: CWE-89
Description
GLPI is a Free Asset and IT Management Software package. Prior to 10.0.15, an authenticated user can exploit a SQL injection vulnerability from map search. This vulnerability is fixed in 10.0.15.
Affected products
- glpi-project glpi: from 9.3.0 before 10.0.15 — fixed in 10.0.15
How to fix
Upgrade to a fixed version: glpi-project glpi 10.0.15. Check the vendor advisory for mitigations.
References
- https://github.com/glpi-project/glpi/commit/730c3db29a1edc32f9b9d1e2a940e90a0211ab26
- https://github.com/glpi-project/glpi/security/advisories/GHSA-gcj4-2cp3-6h5j
- https://github.com/glpi-project/glpi/commit/730c3db29a1edc32f9b9d1e2a940e90a0211ab26
- https://github.com/glpi-project/glpi/security/advisories/GHSA-gcj4-2cp3-6h5j
Get alerted when CVE-2024-31456 or the next vulnerability affects your stack