What’s Vulnerable › Vulnerabilities
CVE-2024-31469
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-14 · updated 2026-06-17
- Weakness: CWE-121
Description
There are buffer overflow vulnerabilities in the underlying Central Communications service that could lead to unauthenticated remote code execution by sending specially crafted packets destined to the PAPI (Aruba's Access Point management protocol) UDP port (8211). Successful exploitation of these vulnerabilities result in the ability to execute arbitrary code as a privileged user on the underlying operating system.
Affected products
- Hewlett Packard Enterprise (HPE) ArubaOS (AOS): from 10.3.0.0 before 10.4.1.1; from 10.5.0.0 before 10.5.1.1 — fixed in 10.4.1.1, 10.5.1.1
- Hewlett Packard Enterprise (HPE) HPE Aruba Networking InstantOS and Aruba Access Points running ArubaOS 10: from 6.4.0.0 before 8.6.0.24; from 8.7.0.0 before 8.10.0.11 — fixed in 8.10.0.11, 8.6.0.24
How to fix
Upgrade to a fixed version: Hewlett Packard Enterprise (HPE) ArubaOS (AOS) 10.4.1.1, 10.5.1.1; Hewlett Packard Enterprise (HPE) HPE Aruba Networking InstantOS and Aruba Access Points running ArubaOS 10 8.10.0.11, 8.6.0.24. Check the vendor advisory for mitigations.
References
- https://support.hpe.com/hpesc/public/docDisplay?docId=hpesbnw04647en_us&docLocale=en_US
- https://www.arubanetworks.com/assets/alert/ARUBA-PSA-2024-006.txt
Get alerted when CVE-2024-31469 or the next vulnerability affects your stack