What’s Vulnerable › Vulnerabilities
CVE-2024-31476
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-14 · updated 2026-06-17
- Weakness: CWE-78
Description
Multiple authenticated command injection vulnerabilities exist in the command line interface. Successful exploitation of these vulnerabilities result in the ability to execute arbitrary commands as a privileged user on the underlying operating system.
Affected products
- Hewlett Packard Enterprise (HPE) ArubaOS (AOS): from 10.3.0.0 before 10.4.1.1; from 10.5.0.0 before 10.5.1.1 — fixed in 10.4.1.1, 10.5.1.1
- Hewlett Packard Enterprise (HPE) HPE Aruba Networking InstantOS and Aruba Access Points running ArubaOS 10: from 6.4.0.0 before 8.6.0.24; from 8.7.0.0 before 8.10.0.11 — fixed in 8.10.0.11, 8.6.0.24
How to fix
Upgrade to a fixed version: Hewlett Packard Enterprise (HPE) ArubaOS (AOS) 10.4.1.1, 10.5.1.1; Hewlett Packard Enterprise (HPE) HPE Aruba Networking InstantOS and Aruba Access Points running ArubaOS 10 8.10.0.11, 8.6.0.24. Check the vendor advisory for mitigations.
References
- https://support.hpe.com/hpesc/public/docDisplay?docId=hpesbnw04647en_us&docLocale=en_US
- https://www.arubanetworks.com/assets/alert/ARUBA-PSA-2024-006.txt
Get alerted when CVE-2024-31476 or the next vulnerability affects your stack