What’s Vulnerable › Vulnerabilities
CVE-2024-31483
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-14 · updated 2026-06-17
Description
An authenticated sensitive information disclosure vulnerability exists in the CLI service accessed via the PAPI protocol. Successful exploitation of this vulnerability results in the ability to read arbitrary files in the underlying operating system.
Affected products
- Hewlett Packard Enterprise (HPE) ArubaOS (AOS): from 10.3.0.0 before 10.4.1.1; from 10.5.0.0 before 10.5.1.1 — fixed in 10.4.1.1, 10.5.1.1
- Hewlett Packard Enterprise (HPE) HPE Aruba Networking InstantOS and Aruba Access Points running ArubaOS 10: from 6.4.0.0 before 8.6.0.24; from 8.7.0.0 before 8.10.0.11 — fixed in 8.10.0.11, 8.6.0.24
How to fix
Upgrade to a fixed version: Hewlett Packard Enterprise (HPE) ArubaOS (AOS) 10.4.1.1, 10.5.1.1; Hewlett Packard Enterprise (HPE) HPE Aruba Networking InstantOS and Aruba Access Points running ArubaOS 10 8.10.0.11, 8.6.0.24. Check the vendor advisory for mitigations.
References
- https://support.hpe.com/hpesc/public/docDisplay?docId=hpesbnw04647en_us&docLocale=en_US
- https://www.arubanetworks.com/assets/alert/ARUBA-PSA-2024-006.txt
Get alerted when CVE-2024-31483 or the next vulnerability affects your stack