What’s Vulnerable › Vulnerabilities
CVE-2024-31485
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-14 · updated 2026-06-17
- Weakness: CWE-77
Description
A vulnerability has been identified in CPCI85 Central Processing/Communication (All versions < V5.30), SICORE Base system (All versions < V1.3.0). The web interface of affected devices is vulnerable to command injection due to missing server side input sanitation. This could allow an authenticated privileged remote attacker to execute arbitrary code with root privileges.
Affected products
- Siemens Cpci85 Firmware: before V5.30 — fixed in V5.30
- Siemens SICORE Base system: before V1.3.0 — fixed in V1.3.0
How to fix
Upgrade to a fixed version: Siemens Cpci85 Firmware V5.30; Siemens SICORE Base system V1.3.0. Check the vendor advisory for mitigations.
References
- http://seclists.org/fulldisclosure/2024/Jul/4
- https://cert-portal.siemens.com/productcert/html/ssa-871704.html
- http://seclists.org/fulldisclosure/2024/Jul/4
- https://cert-portal.siemens.com/productcert/html/ssa-871704.html
Get alerted when CVE-2024-31485 or the next vulnerability affects your stack