What’s Vulnerable › Vulnerabilities

CVE-2024-31489

Description

AAn improper certificate validation vulnerability [CWE-295] in FortiClientWindows 7.2.0 through 7.2.2, 7.0.0 through 7.0.11, FortiClientLinux 7.2.0, 7.0.0 through 7.0.11 and FortiClientMac 7.0.0 through 7.0.11, 7.2.0 through 7.2.4 may allow a remote and unauthenticated attacker to perform a Man-in-the-Middle attack on the communication channel between the FortiGate and the FortiClient during the ZTNA tunnel creation

Affected products

How to fix

Upgrade to a fixed version: Fortinet FortiClientWindows 7.0.12, 7.2.3, 7.2.5. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-31489 or the next vulnerability affects your stack