What’s Vulnerable › Vulnerabilities
CVE-2024-3152: Privilege Escalation and Local File Inclusion in mintplex-labs/anything-llm
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-06-06 · updated 2026-06-17
- Weakness: CWE-918
Description
mintplex-labs/anything-llm is vulnerable to multiple security issues due to improper input validation in several endpoints. An attacker can exploit these vulnerabilities to escalate privileges from a default user role to an admin role, read and delete arbitrary files on the system, and perform Server-Side Request Forgery (SSRF) attacks. The vulnerabilities are present in the `/request-token`, `/workspace/:slug/thread/:threadSlug/update`, `/system/remove-logo`, `/system/logo`, and collector's `/process` endpoints. These issues are due to the application's failure to properly validate user input before passing it to `prisma` functions and other critical operations. Affected versions include the latest version prior to 1.0.0.
Affected products
- Mintplexlabs Anythingllm: before 1.0.0 — fixed in 1.0.0
How to fix
Upgrade to a fixed version: Mintplexlabs Anythingllm 1.0.0. Check the vendor advisory for mitigations.
References
- https://github.com/mintplex-labs/anything-llm/commit/200bd7f0615347ed2efc07903d510e5a208b0afc
- https://huntr.com/bounties/46034fa0-d623-49f8-8ee8-390390181373
- https://github.com/mintplex-labs/anything-llm/commit/200bd7f0615347ed2efc07903d510e5a208b0afc
- https://huntr.com/bounties/46034fa0-d623-49f8-8ee8-390390181373
Get alerted when CVE-2024-3152 or the next vulnerability affects your stack