What’s Vulnerable › Vulnerabilities
CVE-2024-31573
- Severity: medium (CVSS 4.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-17 · updated 2026-10-02
- Weakness: CWE-669
Description
XMLUnit for Java before 2.10.0, in the default configuration, might allow code execution via an untrusted stylesheet (used for an XSLT transformation), because XSLT extension functions are enabled.
Affected products
- XMLUnit for Java: from 2.0.0 before 2.10.0 — fixed in 2.10.0
How to fix
Upgrade to a fixed version: XMLUnit for Java 2.10.0. Check the vendor advisory for mitigations.
References
- https://github.com/advisories/GHSA-chfm-68vv-pvw5
- https://github.com/xmlunit/xmlunit/commit/b81d48b71dfd2868bdfc30a3e17ff973f32bc15b
- https://github.com/xmlunit/xmlunit/issues/264
- https://github.com/xmlunit/xmlunit/issues/264
Get alerted when CVE-2024-31573 or the next vulnerability affects your stack