What’s Vulnerable › Vulnerabilities
CVE-2024-31580
- Severity: medium (CVSS 4.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-17 · updated 2026-06-17
- Weakness: CWE-122
Description
PyTorch before v2.2.0 was discovered to contain a heap buffer overflow vulnerability in the component /runtime/vararg_functions.cpp. This vulnerability allows attackers to cause a Denial of Service (DoS) via a crafted input.
Affected products
- PyTorch: before 2.2.0 — fixed in 2.2.0
How to fix
Upgrade to a fixed version: PyTorch 2.2.0. Check the vendor advisory for mitigations.
References
- https://gist.github.com/1047524396/038c78f2f007345e6f497698ace2aa3d
- https://github.com/pytorch/pytorch/commit/b5c3a17c2c207ebefcb85043f0cf94be9b2fef81
- https://gist.github.com/1047524396/038c78f2f007345e6f497698ace2aa3d
- https://github.com/pytorch/pytorch/commit/b5c3a17c2c207ebefcb85043f0cf94be9b2fef81
Get alerted when CVE-2024-31580 or the next vulnerability affects your stack