What’s Vulnerable › Vulnerabilities
CVE-2024-31583
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-17 · updated 2026-06-17
- Weakness: CWE-416
Description
Pytorch before version v2.2.0 was discovered to contain a use-after-free vulnerability in torch/csrc/jit/mobile/interpreter.cpp.
Affected products
- PyTorch: before 2.2.0 — fixed in 2.2.0
How to fix
Upgrade to a fixed version: PyTorch 2.2.0. Check the vendor advisory for mitigations.
References
- https://gist.github.com/1047524396/43e19a41f2b36503a4a228c32cdbc176
- https://github.com/pytorch/pytorch/blob/v2.1.2/torch/csrc/jit/mobile/interpreter.cpp#L132
- https://github.com/pytorch/pytorch/commit/9c7071b0e324f9fb68ab881283d6b8d388a4bcd2
- https://gist.github.com/1047524396/43e19a41f2b36503a4a228c32cdbc176
- https://github.com/pytorch/pytorch/blob/v2.1.2/torch/csrc/jit/mobile/interpreter.cpp#L132
- https://github.com/pytorch/pytorch/commit/9c7071b0e324f9fb68ab881283d6b8d388a4bcd2
Get alerted when CVE-2024-31583 or the next vulnerability affects your stack