What’s Vulnerable › Vulnerabilities
CVE-2024-31617
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-22 · updated 2026-06-17
- Weakness: CWE-770
Description
OpenLiteSpeed before 1.8.1 mishandles chunked encoding.
Affected products
- LiteSpeed Technologies OpenLiteSpeed: before 1.8.1 — fixed in 1.8.1
How to fix
Upgrade to a fixed version: LiteSpeed Technologies OpenLiteSpeed 1.8.1. Check the vendor advisory for mitigations.
References
- https://github.com/litespeedtech/openlitespeed/releases/tag/v1.8.1
- https://github.com/litespeedtech/openlitespeed/releases/tag/v1.8.1
Get alerted when CVE-2024-31617 or the next vulnerability affects your stack