What’s Vulnerable › Vulnerabilities
CVE-2024-3166: Cross-Site Scripting (XSS) Vulnerability in mintplex-labs/anything-llm
- Severity: critical (CVSS 9.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-06-06 · updated 2026-06-17
- Weakness: CWE-79
Description
A Cross-Site Scripting (XSS) vulnerability exists in mintplex-labs/anything-llm, affecting both the desktop application version 1.2.0 and the latest version of the web application. The vulnerability arises from the application's feature to fetch and embed content from websites into workspaces, which can be exploited to execute arbitrary JavaScript code. In the desktop application, this flaw can be escalated to Remote Code Execution (RCE) due to insecure application settings, specifically the enabling of 'nodeIntegration' and the disabling of 'contextIsolation' in Electron's webPreferences. The issue has been addressed in version 1.4.2 of the desktop application.
Affected products
- Mintplexlabs Anythingllm Desktop: before 1.4.2 — fixed in 1.4.2
- Mintplexlabs Anythingllm Docker: through 1.2.0
How to fix
Upgrade to a fixed version: Mintplexlabs Anythingllm Desktop 1.4.2. Check the vendor advisory for mitigations.
References
- https://github.com/mintplex-labs/anything-llm/commit/fa27103d032c58904c49b92ee13fabc19a20a5ce
- https://huntr.com/bounties/af288bd3-8824-4216-a294-ae9fb444e5db
- https://github.com/mintplex-labs/anything-llm/commit/fa27103d032c58904c49b92ee13fabc19a20a5ce
- https://huntr.com/bounties/af288bd3-8824-4216-a294-ae9fb444e5db
Get alerted when CVE-2024-3166 or the next vulnerability affects your stack