What’s Vulnerable › Vulnerabilities
CVE-2024-3167: Ocean Extra <= 2.2.6 - Authenticated (Contributor+) Stored Cross-Site Scripting
- Severity: medium (CVSS 6.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-09 · updated 2026-06-17
- Weakness: CWE-79
Description
The Ocean Extra plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘twitter_username’ parameter in versions up to, and including, 2.2.6 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level permissions and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- oceanwp Ocean Extra: before 2.2.7 — fixed in 2.2.7
How to fix
Upgrade to a fixed version: oceanwp Ocean Extra 2.2.7. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/ocean-extra/tags/2.2.6/includes/widgets/social-share.php#L269
- https://plugins.trac.wordpress.org/changeset/3066649/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/a292579c-9755-4bd4-996c-23d19ca1c197?source=cve
- https://plugins.trac.wordpress.org/browser/ocean-extra/tags/2.2.6/includes/widgets/social-share.php#L269
- https://plugins.trac.wordpress.org/changeset/3066649/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/a292579c-9755-4bd4-996c-23d19ca1c197?source=cve
Get alerted when CVE-2024-3167 or the next vulnerability affects your stack