What’s Vulnerable › Vulnerabilities
CVE-2024-31670
- Severity: medium (CVSS 6.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-12 · updated 2026-06-17
- Weakness: CWE-120
Description
rizin before v0.6.3 is vulnerable to Buffer Overflow via create_cache_bins, read_cache_accel, and rz_dyldcache_new_buf functions in librz/bin/format/mach0/dyldcache.c.
Affected products
- rizinorg rizin: before 0.6.3 — fixed in 0.6.3
How to fix
Upgrade to a fixed version: rizinorg rizin 0.6.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-31670 or the next vulnerability affects your stack