What’s Vulnerable › Vulnerabilities
CVE-2024-31835
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-10-01 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross Site Scripting vulnerability in flatpress CMS Flatpress v1.3 allows a remote attacker to execute arbitrary code via a crafted payload to the file name parameter.
Affected products
- flatpressblog/flatpress: before 1.3 — fixed in 1.3
How to fix
Upgrade to a fixed version: flatpressblog/flatpress 1.3. Check the vendor advisory for mitigations.
References
- https://drive.google.com/file/d/1OthtP87MduNTYur_p0RZv3moY8CrBcaM/view
- https://github.com/paragbagul111/CVE-2024-31835
Get alerted when CVE-2024-31835 or the next vulnerability affects your stack